mds/www-apps/glpi/glpi-0.78.2.ebuild

41 lines
845 B
Bash

# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
inherit webapp eutils
DESCRIPTION="GLPI is the Information Resource-Manager with an additional Administration- Interface"
HOMEPAGE="http://glpi-project.org/"
SRC_URI="https://forge.indepnet.net/attachments/download/772/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="${DEPEND}
app-admin/webapp-config"
RDEPEND="${DEPEND}
virtual/php
virtual/mysql"
S=${WORKDIR}/"glpi"
src_install() {
webapp_src_preinst
einfo "Copying main files"
cd ${S}
cp -r . ${D}/${MY_HTDOCSDIR} || die
#All files must be owned by server
for i in $(find . -print) ; do
webapp_serverowned ${MY_HTDOCSDIR}/$i || die
done
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}