overlay/dev-embedded/u-boot-tools/u-boot-tools-2017.05.ebuild

48 lines
1.1 KiB
Bash

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
MY_P="u-boot-${PV/_/-}"
DEB_PV="2017.05+dfsg1-1"
DESCRIPTION="utilities for working with Das U-Boot"
HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2
mirror://debian/pool/main/u/u-boot/u-boot_${DEB_PV}.debian.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""
S=${WORKDIR}/${MY_P}
src_compile() {
# Unset a few KBUILD variables. Bug #540476
unset KBUILD_OUTPUT KBUILD_SRC
emake defconfig
emake \
HOSTSTRIP=: \
STRIP=: \
HOSTCC="$(tc-getCC)" \
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
HOSTLDFLAGS="${LDFLAGS}" \
CONFIG_ENV_OVERWRITE=y \
tools-all
}
src_install() {
cd tools || die
dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
dobin easylogo/easylogo
dobin env/fw_printenv
dosym fw_printenv /usr/bin/fw_setenv
insinto /etc
doins env/fw_env.config
insinto /etc/fw_env.d
"${WORKDIR}"/debian/env-configs/*.config
doman "${S}"/doc/mkimage.1 "${WORKDIR}"/debian/manpages/*.8
}